Heartbleed Security Update

On April 7 2014, a security vulnerability in OpenSSL known as Heartbleed was publicly disclosed. OpenSSL is an encryption library that powers the majority of SSL web sites; thus many popular ones like Google and Amazon were affected.

Though we have no reason to believe anybody targeted Qualaroo maliciously, we've taken the steps to fix the exploit and mitigate any potential abuse as recommended by Amazon Web Services.

You may receive emails or see notices from other services recommending you change your password. If you share a password between Qualaroo and any other web site, we recommend that you change your password in case the other web site was compromised.

If you have any questions, please contact us at support@qualaroo.com.

Morgan Sherwood
Sr. Customer Success Manager

Have more questions? Submit a request
Powered by Zendesk